FSX stops running after FI startup screen and button press

All things CV1 and Flyinside related.

Moderators: Tony, Sharkku

FSX stops running after FI startup screen and button press

Postby Peter3210 » Sun Jul 10, 2016 3:35 pm

When I click on the FlyInside icon on my PC's desktop FSX starts up on my desktop and I see the Flyinside startup screen inside my Oculus CV1. The problem is that I can't get past the FlyInside startup screen; the FI startup screen says "press any joystick button to recenter your headset position; you may disable this notification from FlyInside settings". I don't have a joystick yet but I thought I could use the XBox controller to at least get started; however when I press the "X" key on my XBox controller I see a message on my desktop saying that "Microsoft Flight Simulator has stopped working"; inside my Oculus all I see is an hourglass over the FI startup screen; the hourglass never goes away because FSX has stopped working. Did I make a mistake in using the XBox Controller? Would buying a joystick solve my problem? If not how would I get past the FI startup screen? Also how does one finding the FlyInside settings in order to disable the notification about recentering one's headset position?

EDIT: I forgot to mention that when I press a button on my X-box controller the FI startup screen moves to a second screen "Welcome to FlyInside. You must select an interact button; you will use the interact button to press buttons to move windows and interact with your aircraft. Press a button on your joystick whichis easy to reach.". It is at that point that I see the hourglass which never goes away because Flight Simulator has stopped working.

Thanks,
Peter
Peter3210
 
Posts: 6
Joined: Sun Jul 10, 2016 3:07 pm

Re: FSX stops running after FI startup screen and button pre

Postby Tony » Sun Jul 10, 2016 5:03 pm

Dan will add a feature soon to enable users to try without a Joystick but until then it's a joystick Flyinside looks for :(

Tony
Tony F
Customer Support = contact tony@flyinside-fsx.com
FlyInside Inc.
Tony
 
Posts: 4649
Joined: Sat May 30, 2015 3:20 pm
Location: Rift User

Re: FSX stops running after FI startup screen and button pre

Postby Peter3210 » Sun Jul 10, 2016 7:57 pm

Thanks Tony, I just bought a joystick (a Logitech Extreme 3D Pro). Unfortunately as soon as I press a button on the joystick I get the same "Microsoft Flight Simulator has stopped working" message on my desktop. As before when I press a button on my joystick the FI startup screen moves to a second screen which says "Welcome to FlyInside. You must select an interact button; you will use the interact button to press buttons to move windows and interact with your aircraft. Press a button on your joystick which is easy to reach." I see the hourglass over the FlyInside message inside my Oculus but the hourglass never goes away because Flight Simulator has stopped working.

I assumed that one should start SteamVR beta before starting FlyInside; is that correct? Just to be sure I did it both ways, both with and without SteamVR beta. In both cases Flight Simulator stopped working as soon as I pressed the joystick key (after seeing the FI startup message in my Oculus). Just to make sure that my game cache was correct I clicked on Properties, Local Files, Verify Integrity of Game Cache and completed that process but that didn't help. Also when I started Steam VR beta I saw a message saying "Bluetooth Driver: A driver needs to be installed to complete Link Box installation. SteamVR needs to be restarted after successful installation. 'Dismiss' 'Install' ". I clicked on install and restarted SteamVR but that didn't help either.

Can you think of why Flight Simulator starts out working on my desktop after pressing the FlyInside icon but then stops working as soon as I press a button on my joystick?

Thanks,
Peter
Peter3210
 
Posts: 6
Joined: Sun Jul 10, 2016 3:07 pm

Re: FSX stops running after FI startup screen and button pre

Postby Tony » Mon Jul 11, 2016 6:26 am

Hi Peter, What button on the joystick are you using ? Could you post your system specs and win version for us? Do you have stock FSX or any addons ? Ezdok is a no no for now. Do you have the correct drivers for that joystick? Does FSX start OK without Flyinside running ?

Tony
Tony F
Customer Support = contact tony@flyinside-fsx.com
FlyInside Inc.
Tony
 
Posts: 4649
Joined: Sat May 30, 2015 3:20 pm
Location: Rift User

Re: FSX stops running after FI startup screen and button pre

Postby Peter3210 » Mon Jul 11, 2016 1:36 pm

Hi Tony,

I used button 5 of my Extreme 3D Pro joystick to respond to the startup Flyinside startup screen in my Oculus.

I'm using a Serenity Ultimate Gamer PC from QuietPC. My system has a Core i7 5820K 3.3Ghz processor, a Palit GTX 1080 FE graphics card, Corsair DDR4 Vengeance LPX 16GB (2x8GB) RAM, a GA-X99P-SLI LGA2011-3 ATX mobo, and a Samsung 850 EVO 1TB 2.5in SSD.

My OS is Windows 10 Home 64-bit.

I use the Steam version of FSX with no add-ons. I updated the drivers to the latest VER 5.10.127 dated 14-MAR-2016.
http://support.logitech.com/en_us/product/extreme-3d-pro#download

FSX starts fine on my desktop PC; I flew a plane on my desktop with no issues. FSX continues to run after I click on the FlyInside icon and see the startup FI screen in my Oculus. It is only at the moment I press a button on my joystick that FSX stops working.

Peter
Peter3210
 
Posts: 6
Joined: Sun Jul 10, 2016 3:07 pm

Re: FSX stops running after FI startup screen and button pre

Postby Tony » Mon Jul 11, 2016 3:38 pm

Peter bit confused this end ? You say fsx is still running when you start flyinside ? You should start from the Flyinside icon with steam running in the background and also oculus home running in the background. Just double check in oculus home settings that allow unknown sources has a tick in the box.

And the palit is great isn't it ;)

Tony
Tony F
Customer Support = contact tony@flyinside-fsx.com
FlyInside Inc.
Tony
 
Posts: 4649
Joined: Sat May 30, 2015 3:20 pm
Location: Rift User

Re: FSX stops running after FI startup screen and button pre

Postby Peter3210 » Mon Jul 11, 2016 6:26 pm

Sorry for the confusion, I meant to say that the introduction frame for FSX appears on my desktop after I start Flyinside with no message saying that FSX has stopped working (please see the introduction frame that I've included a picture of below), however I can't actually fly with FSX after starting Flyinside because in order to do that Flyinside instructs me to press the joystick key and when I do that I get the message saying that "Microsoft Flight Simulator has stopped working". On the other hand if I try to fly with FSX by starting FSX within Steam (without starting Flyinside) then I can fly an actual flight inside FSX.

Here's the "introduction frame" I'm referring to that appears on my PC's desktop after I start Flyinside: Image

I'm wondering if I should have bought a different joystick; what's the name of the joystick that you use? If I bought that one then at least I could eliminate that factor as a variable in solving my problem. I did check the "allow unknown sources" in the Oculus home settings and Oculus Home is running in the background when I start from the Flyinside icon with steam running in the background.

I'm also wondering if I should have reset Flyinside FSX settings. I did do that but perhaps I shouldn't have? Finally I'm wondering about the message I get from SteamVR beta saying "Bluetooth Driver. A driver needs to complete Link Box installation". Below that message I see a "Dismiss" and "Install" button. When I click on "Install" nothing appears to happen.

Omg yes I love the GTX1080FE graphics card! I waited a month after receiving my Oculus just to get that card, I didn't want to settle for the 980 after reading about the improved performance stats on the 1080 even though it meant putting my Oculus in a drawer for a month.
Peter3210
 
Posts: 6
Joined: Sun Jul 10, 2016 3:07 pm

Re: FSX stops running after FI startup screen and button pre

Postby admin » Mon Jul 11, 2016 6:53 pm

I think this crash is unrelated to the joystick/controller itself, but rather some strange bug in FlyInside that occurs on the next screen. Could you e-mail me dan@flyinside-fsx.com, link this thread? I'll need to debug on your computer to see what's wrong, haven't seen this bug before!
Your friendly neighborhood developer!
Contact Me: dan@flyinside-fsx.com
admin
Site Admin
 
Posts: 2670
Joined: Tue Feb 06, 2007 8:36 am

Re: FSX stops running after FI startup screen and button pre

Postby Peter3210 » Tue Jul 12, 2016 12:17 pm

Thanks Dan! I sent an E-mail to you last night.

Peter
Peter3210
 
Posts: 6
Joined: Sun Jul 10, 2016 3:07 pm

Re: FSX stops running after FI startup screen and button pre

Postby Vaq » Tue Jul 19, 2016 6:07 am

Bump on this topic, I am having the same issue on my HTC Vive.
Vaq
 
Posts: 1
Joined: Mon Jul 18, 2016 8:57 pm

Next

Return to Oculus Rift CV1

Who is online

Users browsing this forum: No registered users and 1 guest