[Solved]Getting Fatal Error

All things CV1 and Flyinside related.

Moderators: Tony, Sharkku

[Solved]Getting Fatal Error

Postby EdsonMasca » Tue Sep 26, 2017 1:38 pm

Hi everybody,
I'm just trying this VR thing for the first time now, and I learned of FlyInside and its ability to interface the Rift and X-Plane. But I keep getting a fatal error every time; see attached screenshot.

The text file says:

0.540723 Hooks\OpenGL\ViewportArrayTest.cpp 15 Testing GL_AMD_vertex_shader_viewport_index
0.544793 Rendering\OpenGL\OGLShader.cpp 108 Failed to compile shader
0.544806 Rendering\OpenGL\OGLShader.cpp 109 ERROR: 0:1: '' : Incorrect GLSL version: 450
WARNING: 0:4: '#extension' : 'GL_AMD_vertex_shader_viewport_index' is not supported
WARNING: 0:7: 'GL_ARB_explicit_attrib_location' : extension is not available in current GLSL version
WARNING: 0:7: 'GL_ARB_explicit_attrib_location' : extension is not available in current GLSL version
WARNING: 0:7: 'GL_ARB_explicit_attrib_location' : extension is not available in current GLSL version
ERROR: 0:13: 'vertexPosition_modelspace' : undeclared identifier
ERROR: 0:13: 'assign' : cannot convert from 'float' to '3-component vector of float'
ERROR: 0:15: 'gl_ViewportIndex' : undeclared identifier
WARNING: 0:? : 'gl_InstanceID' : variable is not available in current GLSL version
WARNING: 0:15: 'assign' : implicit type conversion allowed from GLSL 1.20
ERROR: 0:16: 'iColor' : undeclared identifier
WARNING: 0:? : 'gl_InstanceID' : variable is not available in current GLSL version
WARNING: 0:? : 'gl_InstanceID' : variable is not available in current GLSL version
ERROR: 0:16: 'assign' : cannot convert from '3-component vector of float' to 'float'


0.5449 Hooks\OpenGL\ViewportArrayTest.cpp 24 Failed to compile shader with extension
0.565885 Hooks\OpenGL\ProgramManager.cpp 54 Linking program 1 - 4 -1 5
1.24965 Hooks\OpenGL\ProgramManager.cpp 54 Linking program 6 - 7 -1 8
4.04044 Utils\Asserts.cpp 48 FlyInside Fatal Error Encountered (W:0)
Rendering\OpenGL\OGLShader.cpp: Line 118
Please post this message to http://flyinside-fsx.com/forum/
Be sure to include what hardware, software, and versions you are running


The problem can't be my graphics card because it's a brand-new ZOTAC GeForce GTX 1080 AMP Extreme with 8GB of GPU RAM.

Versions:
Windows 8.1
Steam v017
X-Plane 11.05r2 (build 110501 64-bit)
Oculus App Version 1.18.0.442021 (1.18.0.442311)
FlyInside XP Pro 1.81 - for X-Plane (Beta) -- It says X-Plane v10.52, latest X-Plane 11 beta is required but the version I'm running is newer. Could that be it? If so what can I do other than downgrade?

Thanks in advance for any suggestions! :)
Attachments
error.png
error.png (18.54 KiB) Viewed 1050 times
EdsonMasca
 
Posts: 4
Joined: Tue Sep 26, 2017 1:32 pm

Re: Getting Fatal Error

Postby Tony » Wed Sep 27, 2017 3:53 am

How do you have the rift plugged in ? No camera utilities or the like ? And no SLI?
Tony F
Customer Support = contact tony@flyinside-fsx.com
FlyInside Inc.
Tony
 
Posts: 4649
Joined: Sat May 30, 2015 3:20 pm
Location: Rift User

Re: Getting Fatal Error

Postby EdsonMasca » Fri Sep 29, 2017 5:34 am

Thank you for your reply, but by the time the admins approved my post I had already solved it, found a new problem -- the one about Steam X-Plane vs. free demo X-Plane on my other thread --, and then solved that as well. haha

Shall I do something about this thread? Perhaps prefix it with "SOLVED"?
EdsonMasca
 
Posts: 4
Joined: Tue Sep 26, 2017 1:32 pm


Return to Oculus Rift CV1

Who is online

Users browsing this forum: No registered users and 1 guest