Head movement lag

All things CV1 and Flyinside related.

Moderators: Tony, Sharkku

Head movement lag

Postby CieloHalcon » Tue Dec 19, 2017 2:49 am

Hey all. I have Oculus CV1 and Prepar3d v4 with the latest paid version of FlyInside.

I'm guessing this is a fairly common issue, but perhaps there is a way to resolve it. After disabling ASW in the FlyInside settings, I've noticed a marked increase in performance. My overall FPS is fine for the most part when I fly planes in VR, but whenever I move my head around, I notice there's a lag in the movement.

This of course causes me to catch a glimpse of the empty black areas surrounding the virtual image. I have the overdraw set to maximum to minimize this, but it's still an issue. Is there a way to resolve this? I'm not exactly yanking my head around abruptly. At most, I'll turn my head at a brisk pace, but even if I turn my head somewhat slowly, I'll still glimpse the outer black areas.
CieloHalcon
 
Posts: 6
Joined: Mon Jan 16, 2017 3:05 am

Re: Head movement lag

Postby Tony » Wed Dec 20, 2017 10:20 am

Try reducing the overdraw and in game turn down some eye candy. This should help with this problem.
Tony F
Customer Support = contact tony@flyinside-fsx.com
FlyInside Inc.
Tony
 
Posts: 4692
Joined: Sat May 30, 2015 3:20 pm
Location: Rift User

Re: Head movement lag

Postby fenflame » Wed Dec 27, 2017 4:11 pm

CieloHalcon wrote:Hey all. I have Oculus CV1 and Prepar3d v4 with the latest paid version of FlyInside.

I'm guessing this is a fairly common issue, but perhaps there is a way to resolve it. After disabling ASW in the FlyInside settings, I've noticed a marked increase in performance. My overall FPS is fine for the most part when I fly planes in VR, but whenever I move my head around, I notice there's a lag in the movement.

This of course causes me to catch a glimpse of the empty black areas surrounding the virtual image. I have the overdraw set to maximum to minimize this, but it's still an issue. Is there a way to resolve this? I'm not exactly yanking my head around abruptly. At most, I'll turn my head at a brisk pace, but even if I turn my head somewhat slowly, I'll still glimpse the outer black areas.


If you look at the FI FPS meter the right number going below 90 is typically whats happening when you have these sort of problems because your system is taxed. 90 is the magic number, the number on the left you want as high as possible, but the one on the right is the main one that affects game play. Sometimes you think you have great FPS because the left number is really high, but the right number has actually tanked causing the issue. I can't see your H/W specs, so assuming you are running a decent spec and the issues are P3d V4 / FI related then by far the biggest causes for these problems are:

a) Having dynamic lighting turned on - This looks great but its an FPS killer inside VR. Turn it off.
b)Having FPS setting in the P3D menus to 'unlimited'. Set it to 60 or 50.
c)Having HDR Turned on - FI doesn't appear to support it. It will drag resources down and you will not gain anything. Turn it off.
d) As my FI mate Tony said, watch your eye candy settings. Try these settings:
i) Set LOD radius to medium.
ii) Tesselation Factor: Ultra
iii) All other setting to 'Normal' or 'Medium'
e) Weather Settings: Having Volumetric Fog turned on kills FPS in certain cloud conditions. Turn it off, with a great weather injector like Active Sky for P3DV4 having it turned off doesn't have a great visual impact.
f) Keep AI traffic down a bit. I've just moved to Ultra Traffic Live and I find its way of injecting models is much more efficient than anything else available. You can have full airports with much less FPS hit than previous traffic programs.
g)Don't try to use any of the SSAA anti-aliasing. Its not supported in FI, but your machine will still be doing all processing. 8xMSAA is the best setting for me.

Finally, even though P3DV4 is a 64bit program , it still has a little bit of difficulty spreading its CPU load efficiently. This procedure may seem a little laborious written down, but I guarantee you will gain FPS and have a smoother time in the sim. This has to be done every time you start up P3DV4. It only takes 30 secs once you are used to doing it and substituting this procedure with a config file AffintyMask setting won't achieve the same results.

1. Once the Simulator has fired up, you are at the airport and ready to start , hit CTRL-ALT-DEL and start the Task Manager from the Menu.
2. Click on > arrow on the left of Prepar3D to expand it/
3. Right click on 'Prepar3d' and Select 'Go to Details'
4. Right click on 'Prepar3d' once you are in the details page and select 'Select Priority' and set it to 'High'. click 'Set Priority' in the window that appears to confirm.
5. Click on the 'Performance' tab up near the top of the task manager window. Look down at the bottom of the window and click 'Open Resource Meter'.
6. Now click on the 'CPU' tab. Monitor the CPU's and you will see one that's almost if not fully maxed out. Make a note of that CPU and close the Resource Monitor.
7. Go back to the Task Manager/Processes Tab, right click on 'Prepar3D' and select 'Details' and once again right click on 'Prepar3D' details. This time select 'Set Affinity'.
8. turn off the CPU that you wrote down and turn off CPU '0' as well. Hit OK in the window.
9. Now select' Set Affinity' again and turn back on the the CPU number you wrote down but leave CPU '0' unchecked.
10 Close task manager and go enjoy a much more stable experience with higher FPS.

The above helps balance the Prepar3D load across all available CPUs and turning off CPU 0 allows other background Windows stuff to use that.
If you use Flight 1'as GTN750, you have an option to allow it to use all or just 1 processor in the setup menu. I suggest dedicating a CPU for it and excluding that CPU in the affinity mask settings above.

Hopefully that will help get you moving in the right direction. Setting up FI to run well with P3DV4 within the constraints of your hardware is like tuning the carbs on a 1960's classic British sports car (E-Type Jag owner here). There are many ways to make them run bad, but when they are right, it's glorious.
Win10-64, i7-4790K OC to 4.7GHZ, 16GB DDR3, EVGA GTX1070 8GB OC, 1 Monitor , CV1, Saitek Rudder Pedals, CH Eclipse Yoke, P3DV4.5
FI P3DV4 Beta Tester. FlyInside Moderator.
fenflame
 
Posts: 91
Joined: Fri Dec 02, 2016 10:42 pm
Location: A Brit who lives in Salem NH, USA

Re: Head movement lag

Postby joepoway » Sun Jan 14, 2018 1:51 am

The above summary is very good.

I would suggest using Process Lasso to do all your core and priority setting it works great and once set it up it will do everything automatically whenever you start any app.

After many years of optimizing FSX, X Plane, DCS and P3D I have found that running P3D on all cores works the best and elevating the priority one notch. I then move all other apps and processes off core 0 (the first core) because it’s the primary rendering core P3D uses. I run things like SPAD.next, Voice Attack, GTN 750 and many other things usually on one or two Cores but never core 0. I actually even take all the many Microsoft op processes off core 0 as well.

Good luck and watch your eye candy particularly auto gen buildings and trees

Joe
i5-2500k @ 4.5Ghz; GTX 1070 G1;32Gb ram; 2 SSD's; Win 10 Pro 64; P3Dv4.2;XP 11;DCS;Aerofly FS 2; All FlyInside Products; Active Sky;SPAD.next;VoiceAttack;Little NavMap;Dynamic FFTF;Process Lasso; 40in 4K TV w/ Native 30 Hz; Oculus Rift CV1; Avid VR user
joepoway
 
Posts: 45
Joined: Fri Jul 29, 2016 5:24 pm


Return to Oculus Rift CV1

Who is online

Users browsing this forum: No registered users and 1 guest

cron