P3Dv4-POOR framerate, tried everything!!

Talk about anything FlyInside related.

Moderators: Tony, Sharkku

Re: P3Dv4-POOR framerate, tried everything!!

Postby fenflame » Sat Mar 24, 2018 9:04 pm

pilotoring wrote:Hi Joe,

I am having the same experience on a system similar to yours, both in hardware and software setup. What I observed is that my cpu utilization is in the range of 40-50% consistently across all cores (you can find out in process lasso or task manager). So the problem is not the weak cpu but the processing power of cpu is not being fully utilized, which explains why changing the sliders does not affect FPS, and also process lasso does not help FPS either in my case.

I have no idea what causes the problem. But one good thing is that I can crank up sliders without lowering FPS. The effect of higher slider setting seems only impact gpu memory usage. Oddly it does not even affect the gpu usage itself, which is always in the 80% range. All these info are gathered from HWmonitor.

Why do you have HT turned off ? My experience was this absolutely killed the frame rate of P3D in VR and increased the flashing issues really badly. While P3D doesn't make great use of HT still , it is much better than V3, but the Oculus software and many other apps do make use of it. If you want proof, just lock Oculus down to one CPU and watch what happens.
A 970, while a great card for most things, barely makes the mark for VR in P3d, especially if you have addons. That's probably your weak link. I had one and upgraded to a 1070 and gained literally 20 to 25% fps and stability.
The weird thing is I have almost identical H/W setup and OS to you guys with very similar addons and I don't suffer anything close to the same issues. If it was something in FI that was causing the issue, all of us with similar setups would experience it, I would have thought.
Win10-64, i7-4790K OC to 4.7GHZ, 16GB DDR3, EVGA GTX1070 8GB OC, 1 Monitor , CV1, Saitek Rudder Pedals, CH Eclipse Yoke, P3DV4
FI P3DV4 Beta Tester.
Posts: 82
Joined: Fri Dec 02, 2016 10:42 pm
Location: A Brit who lives in Salem NH, USA

Re: P3Dv4-POOR framerate, tried everything!!

Postby idefixgallier » Fri Mar 30, 2018 1:12 pm

I have the same problem....

i7-4790k, oc to 4.5, GTX1080TI with P3D 4.2

Outside Flyinside with native VR support locked to 45FPS and stable
with Flyinside it jumps around from 28/17 (most of the time) to 32/95 (if i am lucky)

I admire the idea behind it, but i cant get it usable.
Cpu is 80% in average GPU at 52%

What i have set too... HT off as P3d runs better without on the 4790k. i will try it with HT on tomorrow although i am not sure, if this makes a difference.

Have the oculus beta channel disabled and tried it with Nvidia 388.59 and 391.24 .... no difference
Posts: 16
Joined: Fri Mar 30, 2018 1:03 pm

Re: P3Dv4-POOR framerate, tried everything!!

Postby idefixgallier » Sat Mar 31, 2018 11:02 am

I tested HT on today and .... a significant improvement in Flyinsides Framerate BUT far from stable,
although i have optimized my P3D to get stable above 80 frames

i have no idea whats wrong here
Posts: 16
Joined: Fri Mar 30, 2018 1:03 pm

Re: P3Dv4-POOR framerate, tried everything!!

Postby idefixgallier » Mon Apr 02, 2018 12:58 pm

Try the following:

Stick the Prepar3d process to e.g. cores 0-6 and
let the oculus 64 bit server process work on cores 7-8

The 4970k has enough power to run even the PMDG 737 with ~20FPS
with that settings, Flyinside is running stable at 90FPS all the time ;)

Posts: 16
Joined: Fri Mar 30, 2018 1:03 pm

Re: P3Dv4-POOR framerate, tried everything!!

Postby Tony » Wed Apr 04, 2018 3:30 am

And this is with process lasso or another way . :)
Tony F
Customer Support = contact tony@flyinside-fsx.com
FlyInside Inc.
Posts: 4596
Joined: Sat May 30, 2015 3:20 pm
Location: Rift User

Re: P3Dv4-POOR framerate, tried everything!!

Postby idefixgallier » Wed Apr 04, 2018 8:41 am

Whatever you want to use.
The important thing is ... separate P3D from the oculus process ...
Posts: 16
Joined: Fri Mar 30, 2018 1:03 pm

Re: P3Dv4-POOR framerate, tried everything!!

Postby sawt » Sat Apr 21, 2018 3:59 am


I had similar issues and eventually found it was due to Windows Game mode - I think this feature was introduced with the Windows 10 Fall update last year. Once i disabled it performamance was back to normal - I typically get 40 - 50 fps within FI and i have all the Orbx scenery installed.

Before i disabled Game mode i was getting very low inconsistent frame rates and my mouse kept pausing. To disble Game Mode I ran P3D in non-vr mode activated the game mode bar (can’t remember which hotkey this requires) then click on disable. I had previously tried disbling it from the control panel by clicking on hide game bar but this did not disable anything. I unhide the game bar and then was able to disable the feature.

Posts: 12
Joined: Sun Nov 20, 2016 10:45 am


Return to FlyInside General Discussion

Who is online

Users browsing this forum: No registered users and 1 guest