XP11 extensive testing with flyinside results

Moderators: Tony, Sharkku

Re: XP11 extensive testing with flyinside results

Postby ssites » Wed Jan 11, 2017 10:22 am

Jzig wrote:I just got back from some dataref testing and wanted to leave you this info in case you wanted to play around with them:
Dataref Editor http://www.xsquawkbox.net/xpsdk/mediawiki/File:DataRefEditor_12-11.zip

Put that in your resource\plugins folder and you'll get a menu for it inside the plugins drop down. Most of the useful controls are under the art controls window. It's a little weird, if you find a value you want to change, click or double click on the actual value # to get the cursor up. Changes you make in here are not permanent and will be lost when you restart x-plane.

Anyway, most important finding for me was turning off cockpit shadows, which gave me a 3-5 FPS gain.
Image

I've also been using Process Explorer from the sysinternals suite to monitor CPU/GPU consumption with more detail. Right now my hunch is that I'm GPU limited by object geometry/density... not HDR, textures, AA, or anything like that. I'm a little confused by that because my understanding was always that object density and geometry is CPU side, but I'm not seeing my CPU struggling and I was monitoring all cores individually. Could be something to do with the way it's measured for the graphing? Anyway, the # objects is big factor in FPS and more so in stutter when looking in new directions. It isn't nearly as noticeable in 2D but in VR, if you turn your head and it there is a delay to load objects, you get a blackspace.


How do you disable cockpit shadows, or shadows in general? I must be missing this setting somewhere.

duh...never mind I see you did it in Data Ref Editor. I just hope LR gives us some of these options in the main menus eventually
ssites
 
Posts: 42
Joined: Mon Dec 05, 2016 3:52 pm

Re: XP11 extensive testing with flyinside results

Postby ssites » Wed Jan 11, 2017 10:51 am

theskyisthelimit99 wrote:not sure if i mentioned this before, but.. if you put these in a .lua script you gain about 10 fps in the rift...

set("sim/private/controls/caps/use_csm", 0.000000)
set("sim/private/controls/perf/disable_shadow_prep", 1.000000)



Basically kills shadows i believe.


My fps at least on the ATW took a hit with Beta 5 (averaging 70-92 whereas before it was a solid 90-92).. this seemed to bring it up a bit, along with the sim rate.



Do you just take a blank LUA script file and paste these 2 lines in it?
ssites
 
Posts: 42
Joined: Mon Dec 05, 2016 3:52 pm

Re: XP11 extensive testing with flyinside results

Postby theskyisthelimit99 » Wed Jan 11, 2017 11:22 am

ssites wrote:
theskyisthelimit99 wrote:not sure if i mentioned this before, but.. if you put these in a .lua script you gain about 10 fps in the rift...

set("sim/private/controls/caps/use_csm", 0.000000)
set("sim/private/controls/perf/disable_shadow_prep", 1.000000)



Basically kills shadows i believe.


My fps at least on the ATW took a hit with Beta 5 (averaging 70-92 whereas before it was a solid 90-92).. this seemed to bring it up a bit, along with the sim rate.



Do you just take a blank LUA script file and paste these 2 lines in it?


Yep that's what I've done. And I now run 8x aa in fi and none in xplane and find full 3840. A bit of shimmering depending on the area in the distance but tolerable for now. Frame rates 30-49. I just wish xenviro fully worked. You end up with this distant wall on the horizon instead of gradual fog. Also clouds as you pass them are often 2d walls, perhaps just how xenviro is
Z170-a | SL Delid 6700k 4.7 1.402-0.008LLC6(vcore=1.44) | F4-3200C15D-16GVK @1.40 at 3466 | TT 3.0 Riing | Thermaltake v51 | Evga 1080FTW Hybrid Water(43c p3d) | Rift | Leap | CH Yoke/Pedals | P3D v3.4.14 and Aerofly FS2 (evo SSD)/XP10(std sata)
Flight-Stew | Tech-Stew
theskyisthelimit99
 
Posts: 142
Joined: Thu Aug 25, 2016 12:34 pm

Re: XP11 extensive testing with flyinside results

Postby ssites » Wed Jan 11, 2017 11:25 am

theskyisthelimit99 wrote:
ssites wrote:
theskyisthelimit99 wrote:not sure if i mentioned this before, but.. if you put these in a .lua script you gain about 10 fps in the rift...

set("sim/private/controls/caps/use_csm", 0.000000)
set("sim/private/controls/perf/disable_shadow_prep", 1.000000)



Basically kills shadows i believe.


My fps at least on the ATW took a hit with Beta 5 (averaging 70-92 whereas before it was a solid 90-92).. this seemed to bring it up a bit, along with the sim rate.



Do you just take a blank LUA script file and paste these 2 lines in it?


Yep that's what I've done. And I now run 8x aa in fi and none in xplane and find full 3840. A bit of shimmering depending on the area in the distance but tolerable for now. Frame rates 30-49. I just wish xenviro fully worked. You end up with this distant wall on the horizon instead of gradual fog. Also clouds as you pass them are often 2d walls, perhaps just how xenviro is


Very cool thanks! I will try when I get home tonight
ssites
 
Posts: 42
Joined: Mon Dec 05, 2016 3:52 pm

Re: XP11 extensive testing with flyinside results

Postby theskyisthelimit99 » Wed Jan 11, 2017 11:46 am

ssites wrote:
Very cool thanks! I will try when I get home tonight


Be sure to share your results.. hopefully it helps :) Be aware that disabling AA in the sim requires a restart of XP, otherwise your results will vary wildly.
Z170-a | SL Delid 6700k 4.7 1.402-0.008LLC6(vcore=1.44) | F4-3200C15D-16GVK @1.40 at 3466 | TT 3.0 Riing | Thermaltake v51 | Evga 1080FTW Hybrid Water(43c p3d) | Rift | Leap | CH Yoke/Pedals | P3D v3.4.14 and Aerofly FS2 (evo SSD)/XP10(std sata)
Flight-Stew | Tech-Stew
theskyisthelimit99
 
Posts: 142
Joined: Thu Aug 25, 2016 12:34 pm

Re: XP11 extensive testing with flyinside results

Postby ssites » Wed Jan 11, 2017 11:58 am

theskyisthelimit99 wrote:
ssites wrote:
Very cool thanks! I will try when I get home tonight


Be sure to share your results.. hopefully it helps :) Be aware that disabling AA in the sim requires a restart of XP, otherwise your results will vary wildly.


Absolutely. On another note, I saw somewhere else that someone said they set the monitor frame rate really low to increase the Rift frame rate. I am having lots of fps issues, and I do leave the window open on the main screen at a high resolution when I am in the Rift. They said the monitor can kill the Rift fps if it is running like that. Any ideas on how to lower the monitor frame rate, or should i just hide the window on the screen?
ssites
 
Posts: 42
Joined: Mon Dec 05, 2016 3:52 pm

Re: XP11 extensive testing with flyinside results

Postby theskyisthelimit99 » Wed Jan 11, 2017 12:09 pm

ssites wrote:
theskyisthelimit99 wrote:
ssites wrote:
Very cool thanks! I will try when I get home tonight


Be sure to share your results.. hopefully it helps :) Be aware that disabling AA in the sim requires a restart of XP, otherwise your results will vary wildly.


Absolutely. On another note, I saw somewhere else that someone said they set the monitor frame rate really low to increase the Rift frame rate. I am having lots of fps issues, and I do leave the window open on the main screen at a high resolution when I am in the Rift. They said the monitor can kill the Rift fps if it is running like that. Any ideas on how to lower the monitor frame rate, or should i just hide the window on the screen?


Actually i asked that same question.. the dev says (I think it was Dan), said that he intended to actually remove the monitor fps option from FI as it really has no affect on the frame rate in the sim like was once believed.. so i dont think thats an issue at this point.
Z170-a | SL Delid 6700k 4.7 1.402-0.008LLC6(vcore=1.44) | F4-3200C15D-16GVK @1.40 at 3466 | TT 3.0 Riing | Thermaltake v51 | Evga 1080FTW Hybrid Water(43c p3d) | Rift | Leap | CH Yoke/Pedals | P3D v3.4.14 and Aerofly FS2 (evo SSD)/XP10(std sata)
Flight-Stew | Tech-Stew
theskyisthelimit99
 
Posts: 142
Joined: Thu Aug 25, 2016 12:34 pm

Re: XP11 extensive testing with flyinside results

Postby Tony » Wed Jan 11, 2017 12:56 pm

That's correct, resolution on the monitor has no effect or impact in the rift.

Tony
Tony F
Customer Support = contact tony@flyinside-fsx.com
FlyInside Inc.
Tony
 
Posts: 4759
Joined: Sat May 30, 2015 3:20 pm
Location: Rift User

Re: XP11 extensive testing with flyinside results

Postby frankbicknell » Fri Jan 13, 2017 7:29 am

I would think that the resolution and frame rate of the monitor does have an impact. It takes 'power' to produce the graphics on the screen. Power that would otherwise be used for the HMD. Unless you are able to use two different graphics processors 1 for HMD 1 for display. I have tried that but it does not work for me. I would like to be able to turn off all output the monitor. I believe that would help improve things. If you have a 4k monitor it takes a lot just to light up all of those pixels.
Z370 Chipset ASUS MB, I7 8700, 32Gb DDR4, M.2 - SSD, Win 10 64
GEForce 1080 TI SC@ Hybrid, Oculus HMD, Saitek X52 pro, Saitek pro cessna
frankbicknell
 
Posts: 56
Joined: Fri Jul 01, 2016 3:37 pm

Re: XP11 extensive testing with flyinside results

Postby theskyisthelimit99 » Fri Jan 13, 2017 10:19 pm

My initial tests comparing PB3 with PB6 seem to show no difference in FPS (edit: actually maybe about 2 fps Less), this using NYCX DD as a baseline with flyinside + vr and clear skies.. still getting the same rate.. 40-43 initially aimed at the city from a few miles back (about 34fps with partly cloudy Xenviro going on), this also with CSM turned off via a LUA script (cockpit/wing shadows)

If i turn back to default the cockpit shadows (CSM) i see about 34 fps instead of the 40 before Xenviro loads under PB6 (again, in pb3, with csm shadows off around 42 or so).
Z170-a | SL Delid 6700k 4.7 1.402-0.008LLC6(vcore=1.44) | F4-3200C15D-16GVK @1.40 at 3466 | TT 3.0 Riing | Thermaltake v51 | Evga 1080FTW Hybrid Water(43c p3d) | Rift | Leap | CH Yoke/Pedals | P3D v3.4.14 and Aerofly FS2 (evo SSD)/XP10(std sata)
Flight-Stew | Tech-Stew
theskyisthelimit99
 
Posts: 142
Joined: Thu Aug 25, 2016 12:34 pm

PreviousNext

Return to XP11 Bug Reporting Here *Discontinued* 25th Jan 2019

Who is online

Users browsing this forum: Google [Bot] and 1 guest