Page 1 of 1

JARDesigns A320 - a couple of issues

PostPosted: Fri Apr 07, 2017 1:19 am
by Greyman
The A320 addon has a few functions,selectable from the FI sim window only, for fuel, loading, ATC for example, that can also be displayed in a separate Windows window. Unfortunately, although these work when using XPlane on its own, via FI the Windows just look empty, whether you import them into the cockpit or not. As this will probably just relate to one set of addons, it will probably not be that high a priority, but thought it worth mentioning just in case there is an easy solution.

Secondly, and this is an odd one, there appears to be a fairly consistent issue with the yaw axis not working when I first start a session of flying. In short, when I have been through the flight planning/cockpit setup phases of the flight, including switching to the FI Sim window to load passengers, cargo and fuel etc,when I try to taxi, the rudder pedals yaw axis will just not work. The toe brakes work and the controller setup screens show that the pedals are sending values to Xplane, but the plane will just not turn. I had made sure that the tiller button and the nose wheel steering switch was set correctly and that the tow crew had removed the pin from the front wheel, by calling, towing for a bit and then dismissing them again.

This one really looked like a JARDesign issue, but as I eventually got the yaw axis working again by going to the FI menu and pressing a few buttons, the exact combination of which I can't remember, but did involve pressing the Sim button.

I have tried the default 737 and the yaw issue does not exist and have also tried the A320 on my monitors, without FI, and again, the rudders work fine, so this looks to be a problem with the way that FI and the A320 plugin interact.

It's no biggy once you have it sorted out, as the problem usually doesn't return, but it is an extra job to do before getting up in the air.

Re: JARDesigns A320 - a couple of issues

PostPosted: Fri Apr 07, 2017 10:48 am
by Greyman
It looks like i am guilty of a bit of finger trouble and an unfortunate choice of buttons for FI.

Due to my A-10c experience in DCS World, i had set button 4 on my joystick as the nose steering button and then, perhaps due to my lack of memory, had used the same button in FI, to toggle full screen mode. As the fact that i had unwittingly deactivated nosewheel steering, which was not shown by anything in the cockpit, it isn't really surprising that the rudder pedals were not working very well. With me constantly switching to the FI Sim window, using button 4, i must have been constantly toggling the nosewheel steering and as those presses would normally come in pairs, i wouldnt normally notice it.

Oh well, on the positive side, at least it can be removed from the list of potential FI bugs and if anyone else does the same thing, or maps the FI fullscreen button to any function that might lead to strange symptoms, this might be a useful lesson. :)