[Solved]HMD Not Detected

Moderators: Tony, Sharkku

[Solved]HMD Not Detected

Postby andradjc » Thu Oct 12, 2017 9:19 pm

Hello All
I have just installed Vive and Stean software on my system,(Windows 10 pro, i7 7700K, 16GB, Zotac 1080 ti 11 GB).
Everything is working fine on the Steam side. The Vive HMD is working fine, since I can navigate on the various steam VR enviroments.
I have X-Plane 11.05 installed and then also installed the FlyInside XP V1.81, but every time I run the X-Plane I get a message telling that the HMD was not dettected. But steam VR shows that it is there and working fine.
I have tried to reinstall Vive and Steam software, but the problem persists.
I would appreciate some help, since I have run out of ideas on solving this. Thanks.
andradjc
 
Posts: 8
Joined: Thu Oct 12, 2017 5:09 pm

Re: HMD Not Detected

Postby Tony » Fri Oct 13, 2017 1:49 am

Hi and a warm welcome. Can you tell us how you have the vive plugged in ? It needs to be plugged directly into the gpu.
Tony F
Customer Support = contact tony@flyinside-fsx.com
FlyInside Inc.
Tony
 
Posts: 4759
Joined: Sat May 30, 2015 3:20 pm
Location: Rift User

Re: HMD Not Detected

Postby andradjc » Fri Oct 13, 2017 7:50 am

Hi Tony,
Thanks a lot!
The vive is plugged directly to the HDMI port at the graphics board. (Zotac 1080 ti).
It works fine for Steam VR apps. Just doesn´t work with Flyinside, that seams to be unable to find the HDM.

Joao.
andradjc
 
Posts: 8
Joined: Thu Oct 12, 2017 5:09 pm

Re: HMD Not Detected

Postby Greyman » Fri Oct 13, 2017 8:55 am

i'm sorry, but i have to ask just to make sure, but you did download the Vive version of FI XP and not the Oculus Rift version?
ASUS Hero VIII Motherboard, I7-6700K, EVGA GTX1080FTW, 48GB RAM, Windows 10
Oculus Rift/Touch
Warthog HOTAS and MFG Crosswind pedals
Greyman
 
Posts: 502
Joined: Sun Apr 02, 2017 6:09 pm

Re: HMD Not Detected

Postby andradjc » Fri Oct 13, 2017 9:59 am

Yes, I have downloaded the vive version for XP, for sure. Unlesse there is a mistake at the FI download page...
Here is the file name downloaded: FLYINSIDE_XP_PRO_1.81_VIVE_1000.
Running this file, everything goes smoothly. It finds the XP 11 folder and completes the installation without any problem.
andradjc
 
Posts: 8
Joined: Thu Oct 12, 2017 5:09 pm

Re: HMD Not Detected

Postby Tony » Fri Oct 13, 2017 10:27 am

Does the vive have something like disable experimental features or similar ??? Try finding that and switch it off. Cannot remember what it's called but remember this causing problems. Do you get an error log at all ? This can be found in the Flyinside folder under the appdata/roaming file tree.
Tony F
Customer Support = contact tony@flyinside-fsx.com
FlyInside Inc.
Tony
 
Posts: 4759
Joined: Sat May 30, 2015 3:20 pm
Location: Rift User

Re: HMD Not Detected

Postby andradjc » Fri Oct 13, 2017 10:58 am

I will try to find the disable experimental features setings...
Here is a copy of the Log file...

0.694855 Hooks\OpenGL\ViewportArrayTest.cpp 15 Testing GL_AMD_vertex_shader_viewport_index
0.696863 Hooks\OpenGL\ViewportArrayTest.cpp 19 Compiled test shader successfully
0.701356 Hooks\OpenGL\ProgramManager.cpp 54 Linking program 1 - 5 -1 6
0.835094 Hooks\OpenGL\ProgramManager.cpp 54 Linking program 7 - 8 -1 9
1.31817 C:\Projects\fsxhook\FSXHook\DI/ServiceLocator.h 25 Binding singleton class Settings::SettingsManager
1.31819 C:\Projects\fsxhook\FSXHook\DI/ServiceLocator.h 25 Binding singleton class Sim::Actions
1.3182 C:\Projects\fsxhook\FSXHook\DI/ServiceLocator.h 25 Binding singleton class Sim::Camera
1.3182 C:\Projects\fsxhook\FSXHook\DI/ServiceLocator.h 25 Binding singleton class Sim::InputStream
1.31821 C:\Projects\fsxhook\FSXHook\DI/ServiceLocator.h 25 Binding singleton struct InferredRenderState
1.31822 C:\Projects\fsxhook\FSXHook\DI/ServiceLocator.h 25 Binding singleton class Sim::FlightSim
1.31822 C:\Projects\fsxhook\FSXHook\DI/ServiceLocator.h 25 Binding singleton class Input::EventSourceAggregator
1.31823 C:\Projects\fsxhook\FSXHook\DI/ServiceLocator.h 25 Binding singleton struct Rendering::OpenGL::GLRunQueue
1.31824 dllmainxp.cpp 129 FlyInside XP Loaded
1.31828 C:\Projects\fsxhook\FSXHook\DI/ServiceLocator.h 25 Binding singleton class FloatUI::ThemeProvider
1.31829 Oculus\Vive1000Hmd.cpp 64 Initializing OpenVR
1.31839 Oculus\Vive1000Hmd.cpp 71 OpenVR Initialization failed
1.3184 Oculus\Vive1000Hmd.cpp 74 Failure reason: 110
4.91614 Utils\Process.cpp 143 Exiting
andradjc
 
Posts: 8
Joined: Thu Oct 12, 2017 5:09 pm

Re: HMD Not Detected

Postby Greyman » Fri Oct 13, 2017 11:13 am

https://www.youtube.com/watch?v=4vRQkRcVYz4

The error message is not exactly the same, but the 110 does appear to identify the same code. I don't have a Vive, so cannot test this out, but it might be worth a look.
ASUS Hero VIII Motherboard, I7-6700K, EVGA GTX1080FTW, 48GB RAM, Windows 10
Oculus Rift/Touch
Warthog HOTAS and MFG Crosswind pedals
Greyman
 
Posts: 502
Joined: Sun Apr 02, 2017 6:09 pm

Re: HMD Not Detected

Postby andradjc » Fri Oct 13, 2017 11:33 am

I have found this post at https://github.com/matzman666/OpenVR-In ... /issues/14

Failed to initialize OpenVR: Installation path could not be located
VR runtime path: Failed to initialize OpenVR: Installation path could not be located (110)
Unable to read VR Path Registry from C:\Users\user\AppData\Local\openvr\openvrpaths.vrpath

I´ve checked for this file and it exist at the same path as above. Here is ir contents:

{
"config" : [ "C:\\Program Files (x86)\\Steam\\config" ],
"external_drivers" : null,
"jsonid" : "vrpathreg",
"log" : [ "C:\\Program Files (x86)\\Steam\\logs" ],
"runtime" : [
"C:\\Program Files (x86)\\Steam\\steamapps\\common\\SteamVR\\",
"C:\\Program Files (x86)\\Steam\\steamapps\\common\\SteamVR"
],
"version" : 1
}

I guessed that FI was having trouble to find the path since the windows 10 was installed in portuguese and the correct path would be " C:\\Arquivos de Programas (x86)\\...", but this usually is not a problem for the applications.
here is a print of the path variable:
PATH=C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common;C:\Users\João Andrade\AppData\Local\Microsoft\WindowsApps;

But, it looks like as if FI is having trouble to find the OpenVr path...
andradjc
 
Posts: 8
Joined: Thu Oct 12, 2017 5:09 pm

Re: HMD Not Detected

Postby Muso-Ka » Fri Oct 13, 2017 12:10 pm

You must write your username in English letters.
C: \ Users \ João Andrade \ AppData \ Local \ Microsoft \ WindowsApps
I7 4930K 3,4 Ghz (4,4 Ghz), Asus Strix GTX 1080Ti OC 11Gb, RAM 32 Gb G Skill 2400, Win 10 64bit - Samsung SSD 850 Pro, Thrustmaster - HOTAS WARTHOG, Saitek - Combat Rudder Pedals, Switch Panel, Multi Panel, TPM System, Oculus Rift CV1+touch, Leap Motion.
Muso-Ka
 
Posts: 150
Joined: Sun Jul 05, 2015 6:20 am
Location: Viana do Castelo, Portugal.

Next

Return to XP11 Bug Reporting Here *Discontinued* 25th Jan 2019

Who is online

Users browsing this forum: No registered users and 1 guest

cron