Page 1 of 1

Looks like XPlane 11.30 just went "stable", broke FlyInside

PostPosted: Sun Jan 13, 2019 3:14 pm
by mthiffault
Steam (without asking me, grr) went and updated XPlane to 11.30. Now when XPlane first starts with FlyInside, I see two XPlane windows (both showing loading screen and progress bar), however the second one goes away by the time they reach the main menu.

Then, when I try to start a flight, one of two things happens:

1. If I try to load an aircraft with REP, something seems to go into a tight loop with the message at the bottom (on the flight loading screen) flickering back and forth between "Done with pre-loading" and "Finished asynchronous loading". It stays like this forever, with the loading progress bar flickering back and forth between two positions. I have to kill XPlane with the task manager.

2. If I load the stock G1000 Cessna 172, I get a popup saying

"There was a problem processing a GLSL shader. You may need to rerun the installer or update your graphics drivers.

Then XPlane dies.

GeForce Experience says my drivers are up to date (I have a GTX 980 TI), and I don't encounter either of these problems if I load XPlane 11 without FlyInside.

I've attached the Log.txt from the shader crash since it's on a stock aircraft and thus hopefully closer to the root cause of the problem.

I'm running Windows 10 with a 6 core/12 hyperthread Xeon processor and 32 GB of RAM.

Re: Looks like XPlane 11.30 just went "stable", broke FlyIns

PostPosted: Sun Jan 13, 2019 4:14 pm
by Fabrice77
Yep, I have exactly the same behaviour.
Tried tio reinstall the Nvidia driver without success.
Tried without HDR on in the XP seetings, the plane seems to be loaded, but steamVR does not display anything. The display on the monitor seems to show the cockpit for a couple of seconds, but the mouse cursor moves by itself all around the window...

Re: Looks like XPlane 11.30 just went "stable", broke FlyIns

PostPosted: Sun Jan 13, 2019 4:25 pm
by mthiffault
I also should have mentioned that I'm using an Oculus CV1, plugged straight into the HDMI on my graphics card, usb in a usb 3.0 port. Interesting to hear Vive users are seeing similar things. I will try without HDR and see what happens.

Re: Looks like XPlane 11.30 just went "stable", broke FlyIns

PostPosted: Sun Jan 13, 2019 4:37 pm
by mthiffault
Ok, so if I disable HDR it actually loads, but the headset and preview screen are just rendering garbage. I see colors that look like panel and sky colors, so it's like it's trying to render the environment but the projection is seriously messed up, with kaleidoscopic effects. Re-centering my view didn't help.