Piper Warrior II yoke not working

Moderators: Tony, Sharkku

Piper Warrior II yoke not working

Postby cvolzke » Wed Jan 03, 2018 8:58 am

I can use every other control - throttle, mixture, master, even flap lever but I can't manipulate the yoke.
I saw that "Piper GA series" by Niel Cornelissen is supported in the 'Recommended Aircraft' notes, I couldn't find that exact thing but had downloaded the warriorrc.zip file from (Niel Cornelissen).
Am I using the wrong version of the Add-On, if so what's the correct version?
Posts: 1
Joined: Wed Jan 03, 2018 8:47 am

Re: Piper Warrior II yoke not working

Postby Greyman » Wed Jan 03, 2018 9:58 am

Hi cvolzke, it's good to have you aboard.

First off, i will apologise if i suggest things that you have already tried or ask what might appear to be simple questions, but i will need to be sure.

1. Has the yoke worked in a version of XPlane without FlyInside? If you haven't tried that, it might be worth doing so, just to eliminate, or otherwise, one possibility.
2. Have you checked the axis settings in XPlane, under the joystick tab in settings? The first thing to check is that XP can actually see your yoke as a valid input device and if it doesn't appear in the Device drop down, then that does sound like a driver issue. Maybe check the USB Game Controls settings via Windows, or the equivalent on whatever OS you are using. If it is visible, your yoke will need to be mapped to the pitch and roll axes and you will probably need to calibrate them. The settings screen will also allow you to check that XP is receiving signals from your yoke, as if you move it, there should be corresponding movements on the pitch and roll indicators.

Let me know how you get on and please add your system details to your signature, as suggested in viewtopic.php?f=3&t=1662, so that we can avoid having to ask about it when you post in future.
ASUS Hero VIII Motherboard, I7-6700K, EVGA GTX1080FTW, 48GB RAM, Windows 10
Oculus Rift/Touch
Warthog HOTAS and MFG Crosswind pedals
Posts: 502
Joined: Sun Apr 02, 2017 6:09 pm

Return to FSX Bug Reporting Here

Who is online

Users browsing this forum: No registered users and 1 guest