logFlyInsideSimulator_settings.txt:Shader compilation failed

Moderators: Tony, admin

logFlyInsideSimulator_settings.txt:Shader compilation failed

Postby AleckoHH » Mon Nov 18, 2019 5:20 pm

Hi guys,

I just updated to version 0.6 after having started the sim for a long time. So far, it worked just perfectly in VR with my oculus. This time, the update itself went without problems, but when I restarted the sim, it just froze in the splash screen. In the logfile (%APPDATA%\FlyInside\logFlyInsideSimulator_settings.txt) I find the following entries with the last line adding up every 5 seconds:

0.00 affinitymanager.cpp:93 Core Masks: 4/16/1345
0.02 simwindow.cpp:204 LoadingTimer: createSimWindow 0.104165 / 0.10417
0.02 simwindow.cpp:243 LoadingTimer: bindBasicRefs 0.0002619 / 0.10443
0.11 simwindow.cpp:251 LoadingTimer: createWindow 0.0841891 / 0.188621
0.11 simwindow.cpp:258 LoadingTimer: createEngine 0.0072224 / 0.195843
0.18 simwindow.cpp:264 LoadingTimer: drawFirst 0.0628162 / 0.25866
0.27 dx11shader.cpp:99 Shader compilation failed for 'Data/Shaders/DX/DynamicAlphaTestInstanced.fx' Error: error X3501: 'VS': entrypoint not found

5.27 dx11shader.cpp:99 Shader compilation failed for 'Data/Shaders/DX/DynamicAlphaTestInstanced.fx' Error: error X3501: 'VS': entrypoint not found

10.27 dx11shader.cpp:99 Shader compilation failed for 'Data/Shaders/DX/DynamicAlphaTestInstanced.fx' Error: error X3501: 'VS': entrypoint not found

15.27 dx11shader.cpp:99 Shader compilation failed for 'Data/Shaders/DX/DynamicAlphaTestInstanced.fx' Error: error X3501: 'VS': entrypoint not found

I am not an expert on graphics- or shader-programming, but it looks as if the update changed the way the shader dx11-routines are being called by the app.

By the way, I didn´t remove or change any contents in the subdirectories. These lines keep coming up every time I start the sim.

Does anyone of you have an idea on how to fix this ?
Any suggestion by the developers would be very welcome.

Best regards, Alex
AleckoHH
 
Posts: 1
Joined: Fri May 17, 2019 12:16 pm

Return to Bugs & Tech Support

Who is online

Users browsing this forum: No registered users and 2 guests