The long pauses and stutters are back!

Moderators: Tony, Sharkku

The long pauses and stutters are back!

Postby 3MonitorsToo » Sat Nov 25, 2017 6:33 pm

This is for X-Plane 10, but I get similar behaviour in X-Plane11.50
Most of the software and hardware info you need is contained in the xplane 10 log file.
Running Oculus home App ver 1.20.0.474906
Running Flyinside ver 1.81

Test conditions:
Rift placed on a chair in the centre of the play area with a lint free cloth placed over the LED/sensor to keep the headset on.
I move the headset slightly and very occasional to keep things alive during flight.
The flight is done by AI only, no joystick input apart from centring the headset view before flight using the appropriate button.

I suspect that these lines may have something to do with the problem:

"Displays\DisplayWindow.cpp 561 Low timewarp FPS detected when ASW should be disabled.
Oculus\ASWControl.cpp 23 Setting ASW enabled: 0"

The above entries in the log file seem to occur at a similar time to when I'm getting the pauses.
On one flight, under the above test condition, I even got a long pause while the aircraft was taxiing, it wasn't even in the air!

Windows update has been disabled on the machine and there was no network activity when the pauses took place.

The three log files (x-plane, Oculus and Flyinside) are attached.

Oculus tray tool is not used.

Steven.
Edit to add: ref to tray tool.
Attachments
xplane 10 Log.txt
(27.23 KiB) Downloaded 61 times
Service_2017-11-25_21.12.25.txt
(632.88 KiB) Downloaded 58 times
flyinside log.txt
(76.93 KiB) Downloaded 58 times
ASROCK Z97 Extreme6 - i7 4970K - 32Gb ram - GTX 980Ti - Windoze 7 pro - Nvidia driver 385.69
Oculus Rift CV1 + Touch controllers. Inateck KTU3FR-4P.
3MonitorsToo
 
Posts: 33
Joined: Fri Jul 21, 2017 9:43 am
Location: 1,500 ft and climbing.

Re: The long pauses and stutters are back!

Postby Stevil » Mon Nov 27, 2017 7:05 am

Can you try a vanilla installation of XP?
CPU Intel i7 4790K - GPU Zotac GTX 1080 Mini - RAM 16gb DDR3 Mobo Gigabyte GAMING 5 - Drive 750GB SSD - OS Win 10 x64 - Simulator X-Plane v11.11 RC1
HTC Vive
Stevil
 
Posts: 1010
Joined: Tue Dec 06, 2016 2:48 pm
Location: EDDK, Cologne / Germany

Re: The long pauses and stutters are back!

Postby 3MonitorsToo » Mon Nov 27, 2017 10:26 pm

Hi Stevil,

As requested, I did a clean vanilla install of X-Plane 10. No third party plugins, scenery or aircraft.
Updated to latest version.
Redid the Oculus sensor setup.
Installed flyinside for the clean XP10 install.

Started flight at EGCC and used one of the default aircraft.
Set weather to CAVOK (I didn't want clouds causing a bottleneck)
Set time of day to mid-day.
All other X-Plane settings are as it comes out of the box - default - I didn't change anything.

Set IA to fly the aircraft.
Put the headset on and centred using the joystick button.

I had at least two long pauses during the end of the very short flight.
Appropriate logs attached.

Many thanks,
Steven.
Attachments
X-PLANE 10 LOG.txt
(27.45 KiB) Downloaded 62 times
Service_2017-11-28_01.48.22.txt
(367.79 KiB) Downloaded 61 times
FLYINSIDE LOG.txt
(135.34 KiB) Downloaded 59 times
ASROCK Z97 Extreme6 - i7 4970K - 32Gb ram - GTX 980Ti - Windoze 7 pro - Nvidia driver 385.69
Oculus Rift CV1 + Touch controllers. Inateck KTU3FR-4P.
3MonitorsToo
 
Posts: 33
Joined: Fri Jul 21, 2017 9:43 am
Location: 1,500 ft and climbing.

Re: The long pauses and stutters are back!

Postby Muso-Ka » Tue Nov 28, 2017 9:41 am

Hi Steven.
In the Nvidia control panel, under the "Power management" section, select the "Maximum performance"
Translated by Google.

Oleg.
I7 4930K 3,4 Ghz (4,4 Ghz), Asus Strix GTX 1080Ti OC 11Gb, RAM 32 Gb G Skill 2400, Win 10 64bit - Samsung SSD 850 Pro, Thrustmaster - HOTAS WARTHOG, Saitek - Combat Rudder Pedals, Switch Panel, Multi Panel, TPM System, Oculus Rift CV1+touch, Leap Motion.
Muso-Ka
 
Posts: 150
Joined: Sun Jul 05, 2015 6:20 am
Location: Viana do Castelo, Portugal.

Re: The long pauses and stutters are back!

Postby 3MonitorsToo » Tue Nov 28, 2017 10:11 am

Hi Oleg,

All my machines are already set up for maximum performance in the Nvidia control panel.

I'm going to give DCS a try, once their website is back up after maintenance.

Steven.
ASROCK Z97 Extreme6 - i7 4970K - 32Gb ram - GTX 980Ti - Windoze 7 pro - Nvidia driver 385.69
Oculus Rift CV1 + Touch controllers. Inateck KTU3FR-4P.
3MonitorsToo
 
Posts: 33
Joined: Fri Jul 21, 2017 9:43 am
Location: 1,500 ft and climbing.

Re: The long pauses and stutters are back!

Postby Tony » Tue Nov 28, 2017 3:48 pm

I got some serious stuuters that I got ird of by uninstalling/rolling back the fall update with win 10......buggered a lot of things up it did !!!
Tony F
Customer Support = contact tony@flyinside-fsx.com
FlyInside Inc.
Tony
 
Posts: 4681
Joined: Sat May 30, 2015 3:20 pm
Location: Rift User

Re: The long pauses and stutters are back!

Postby 3MonitorsToo » Tue Nov 28, 2017 8:55 pm

Tony wrote:I got some serious stuuters that I got ird of by uninstalling/rolling back the fall update with win 10......buggered a lot of things up it did !!!

Hi Tony,

Yes, I heard that from other users on the Oculus forum, but I'm using Windows 7, as shown in my X-Plane log and in my sig.
As I previously stated "Windows update has been disabled on the machine".

The DCS site is back up, but the message says "Sorry, but the file list of the product is currently not available."

Would it be worth me downloading and installing the latest version of Flyinside, I'm still on 1.81?
Would I need to uninstall the old version first?

Thanks,
Steven.
ASROCK Z97 Extreme6 - i7 4970K - 32Gb ram - GTX 980Ti - Windoze 7 pro - Nvidia driver 385.69
Oculus Rift CV1 + Touch controllers. Inateck KTU3FR-4P.
3MonitorsToo
 
Posts: 33
Joined: Fri Jul 21, 2017 9:43 am
Location: 1,500 ft and climbing.

Re: The long pauses and stutters are back!

Postby Muso-Ka » Wed Nov 29, 2017 5:24 am

Hi Steven.
Sorry, maybe a stupid question, how do these stops manifest? Freezing an image or going to the FlyInside menu with "Waiting for the simulator"?
I had freezes of the picture, and this was manifested in all games. The problem was in the video card, I connected the Oculus to another HDMI slot and the problem was gone. I have Windows 10 with all the updates and the latest Nvidia driver. X-Plane 11.10 works excellently.
Translated by Google.
Oleg.
I7 4930K 3,4 Ghz (4,4 Ghz), Asus Strix GTX 1080Ti OC 11Gb, RAM 32 Gb G Skill 2400, Win 10 64bit - Samsung SSD 850 Pro, Thrustmaster - HOTAS WARTHOG, Saitek - Combat Rudder Pedals, Switch Panel, Multi Panel, TPM System, Oculus Rift CV1+touch, Leap Motion.
Muso-Ka
 
Posts: 150
Joined: Sun Jul 05, 2015 6:20 am
Location: Viana do Castelo, Portugal.

Re: The long pauses and stutters are back!

Postby Stevil » Wed Nov 29, 2017 6:44 am

Of course that's worth a try! Update to the latest FlyInside and see if it helps
CPU Intel i7 4790K - GPU Zotac GTX 1080 Mini - RAM 16gb DDR3 Mobo Gigabyte GAMING 5 - Drive 750GB SSD - OS Win 10 x64 - Simulator X-Plane v11.11 RC1
HTC Vive
Stevil
 
Posts: 1010
Joined: Tue Dec 06, 2016 2:48 pm
Location: EDDK, Cologne / Germany

Re: The long pauses and stutters are back!

Postby 3MonitorsToo » Wed Nov 29, 2017 7:52 am

Muso-Ka wrote:Hi Steven.
Sorry, maybe a stupid question, how do these stops manifest? Freezing an image or going to the FlyInside menu with "Waiting for the simulator"?

Hi Oleg,

It's not a stupid question.

The image freezes in the head set for a second or more, sometimes up to six seconds or so.
Sometimes it will drop to the FlyInside menu with "Waiting for the simulator", but this does not always happen.
All the time I'm still getting the engine sounds through the headphones.

The only game I play is Robo Recal and I have never experienced any form of freeze in that game, or any of the other Oculus Home programmes in my library.

When I first got the Rift I was on Oculus Home client ver 1.16 and all was fine, no pauses or stutters.
Then the client updated itself to 1.17 and I then had the problems I'm reporting now.
The problems seemed to clear with the release of the 1.18 client, but the problems are now back with the current release.
I did try the current beta release of the Home client and I got an impressive 72/90 FPS, but the pauses were still there.
I'm getting about 50/90 FPS with my current rendering settings using payware aircraft.

I even spent money getting the Oculus recommended USB 3 add in card and that didn't fix things.
I'm not using any cable extenders, it's just as it came in the box.
I have gone through the room scale several times, moving sensors and making sure that I'm sitting in the centre of the room scale setup - still the same.
I have tried using different USB ports to no avail.
I have spent more time trying to debug this than flying, it's getting very frustrating.

I'm using a GTX 980Ti GPU which only has one HDMI port, my normal monitor is connected a DVI-D port, no adaptors used.
It's also interesting to note that the GPU load (using GPU-Z) drops to zero when the pause takes place and the CPU load shoots up to almost maximum.
The normal loads when flying in the Rift are GPU less than 50% and the CPU at less than 45% in X-plane 10, the CPU load is slightly higher with X-Plane 11.
The pause behaviour is the same when using X-Plane 11.05.

Many thanks for your input Oleg.
Steven.
ASROCK Z97 Extreme6 - i7 4970K - 32Gb ram - GTX 980Ti - Windoze 7 pro - Nvidia driver 385.69
Oculus Rift CV1 + Touch controllers. Inateck KTU3FR-4P.
3MonitorsToo
 
Posts: 33
Joined: Fri Jul 21, 2017 9:43 am
Location: 1,500 ft and climbing.

Next

Return to XP11 Bug Reporting Here *Discontinued* 25th Jan 2019

Who is online

Users browsing this forum: No registered users and 1 guest